首页 > 其他 > 详细

HDU 1010-Tempter of the Bone(DFS+奇偶剪枝)

时间:2014-08-18 18:37:22      阅读:338      评论:0      收藏:0      [点我收藏+]

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 71121    Accepted Submission(s): 19592


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X‘: a block of wall, which the doggie cannot enter; 
‘S‘: the start point of the doggie; 
‘D‘: the Door; or
‘.‘: an empty block.

The input is terminated with three 0‘s. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
NO YES
 
第一次遇到只能DFS过而不能BFS的题(也许是我太菜) 题目要求恰好T步走到终点,而用BFS搜到是最短时间走到终点,BFS一个特点就是没法走回头路,所以BFS无解,我试过用优先队列+不标记 然后MLE了。。只好DFS+奇偶剪枝了,所谓奇偶剪枝,就是假设当前点(x,y)到达终点(ex,ey)恰好为t步时才能得救,可以算出当前点到终点的最短距离s=abs(x-ex)+abs(y-ey) 如果t<s,那肯定到不了了 如果t>s 且(t-s)%2==0 才有可能到达终点 否则是倒不了的 将为奇数的这种情况剪掉
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <vector>
#include <queue>
#include <set>
#include <cmath>
using namespace std;
const int INF=1<<27;
const int maxn=110;
int sx,sy,ex,ey,t,n,m,ok;
bool vis[maxn][maxn];
char ma[maxn][maxn];
int dir[4][2]={{0,1},{0,-1},{-1,0},{1,0}};
void dfs(int x,int y,int t)
{
	vis[x][y]=1;
	if(ok) return ;
	int s=abs(x-ex)+abs(y-ey);
	if(t<s||(t-s)%2) return ;
	if(x<0||y<0||x>=m||y>=n) return ;
	if(t==0&&x==ex&&y==ey){ok=1;return ;}
	for(int i=0;i<4;i++)
	{
		int tx=x+dir[i][0];
		int ty=y+dir[i][1];
		if(tx>=0&&tx<m&&ty>=0&&ty<n&&!vis[tx][ty]&&ma[tx][ty]!='X')
		{
				vis[tx][ty]=1;
				dfs(tx,ty,t-1);
				vis[tx][ty]=0;
		}
	}

}
int main()
{
	int i,j;
	while(cin>>m>>n>>t)
	{
		memset(vis,0,sizeof(vis));
		if(!m&&!n&&!t) break;
		for(i=0;i<m;i++)
			cin>>ma[i];
		for(i=0;i<m;i++)
			for(j=0;j<n;j++)
			if(ma[i][j]=='S')
		    {
			  sx=i;sy=j;
		    }
		    else if(ma[i][j]=='D')
			{
				ex=i;ey=j;
			}
	    ok=0;
		dfs(sx,sy,t);
		if(ok)
        cout<<"YES"<<endl;
        else
		cout<<"NO"<<endl;
	}
	return 0;
}


HDU 1010-Tempter of the Bone(DFS+奇偶剪枝),布布扣,bubuko.com

HDU 1010-Tempter of the Bone(DFS+奇偶剪枝)

原文:http://blog.csdn.net/qq_16255321/article/details/38663299

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!