首页 > Web开发 > 详细

poj 1861 Network (kruskal)

时间:2014-08-19 19:08:05      阅读:381      评论:0      收藏:0      [点我收藏+]

Network
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 13633   Accepted: 5288   Special Judge

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs). 
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections. 
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied. 

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4

Source

Northeastern Europe 2001, Northern Subregion

样例没有错误,因为,只要连通图中最长边最小就行了, 至于边的个数则没有限制,但感觉这题还是很坑!

#include"stdio.h"
#include"string.h"
#include"queue"
#include"algorithm"
using namespace std;
#define N 1005
#define inf 0x7fffffff
int pre[N],ans[N];
struct node
{
    int u,v,d;
}e[N*15];
bool cmp(node a,node b)
{
    return a.d<b.d;
}
int find(int x)
{
    if(x!=pre[x])
        pre[x]=find(pre[x]);
    return pre[x];
}
void kruskal(int n,int m)
{
    int i,f1,f2,j,cnt=0;
    for(i=1;i<=n;i++)
        pre[i]=i;
    for(i=0;i<m;i++)
    {
        f1=find(e[i].u);
        f2=find(e[i].v);
        if(f1!=f2)
        {
            pre[f1]=f2;
            cnt++;
            if(cnt>=n-1)
                break;
        }
    }
    printf("%d\n",e[i].d);
    printf("%d\n",i+1);
    for(j=0;j<=i;j++)
        printf("%d %d\n",e[j].u,e[j].v);
}
int main()
{
    int n,m,i;
    while(~scanf("%d%d",&n,&m))
	{
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].d);
        }
        sort(e,e+m,cmp);
        kruskal(n,m);
	}
    return 0;
}




poj 1861 Network (kruskal),布布扣,bubuko.com

poj 1861 Network (kruskal)

原文:http://blog.csdn.net/u011721440/article/details/38685563

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!