首页 > 其他 > 详细

A+B for Polynomials

时间:2019-11-23 00:02:05      阅读:103      评论:0      收藏:0      [点我收藏+]

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N?1?? a?N?1???? N?2?? a?N?2???? ... N?K?? a?N?K????

where K is the number of nonzero terms in the polynomial, N?i?? and a?N?i???? (,) are the exponents and coefficients, respectively. It is given that 1,0.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

#include<iostream> 
using namespace std;
int main(){
    int m,n,i,temp,count=0;
    float a[1002],b[1002];
    cin>>m;
    for(i=0;i<m;i++){
        cin>>temp;
        cin>>a[temp];
    }
    cin>>n;
    for(i=0;i<n;i++){
        cin>>temp;
        cin>>b[temp];
        if(a[temp]==0){
            a[temp]=b[temp];
        }
        else{
            a[temp]+=b[temp];
        }
    }
    for(i=0;i<1001;i++){
        if(a[i]!=0)
            count++;
    }
    cout<<count;
    for(i=1000;i>=0;i--){
        if(a[i]!=0){
           printf(" %d %.1f",i,a[i]);
        }
    }
    return 0;
}

  

A+B for Polynomials

原文:https://www.cnblogs.com/muchenyu/p/11914863.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!