首页 > 其他 > 详细

POJ 2406 Power Strings

时间:2014-08-25 21:11:14      阅读:289      评论:0      收藏:0      [点我收藏+]

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3
题意:给你一个字符串,要你找到一个最大的n使得a^n=该字符串(a为该字符串的子串)。
思路:既然是找最大的n,那么我只要找该字符串的最小周期,那不正好可以解决这个问题了?依照这个思路来敲代码!
所以AC代码:
#include<stdio.h>
#include<string.h>
#define N 1000005
char str[N];
int main()
{
    int sum;
    while(scanf("%s",str)!=EOF)
    {
        int len=strlen(str);
        if(str[0]=='.')break;
        for(int i=1;i<=len;i++)     //一个剪枝,如果i不能被Len整除,那么i绝对不是字符的周期子串长
            if(len%i==0)
            {
                int ok=1;
                for(int j=i;j<len;j++)
                    if(str[j]!=str[j%i]){ok=0;break;}
                if(ok)
                {
                    sum=i;
                    break;
                }
            }
        printf("%d\n",len/sum);
    }
    return 0;
}


POJ 2406 Power Strings

原文:http://blog.csdn.net/u012313382/article/details/38826369

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!