首页 > 其他 > 详细

[POJ 3264]Balanced Lineup(ST算法求RMQ)

时间:2014-08-25 23:01:45      阅读:506      评论:0      收藏:0      [点我收藏+]

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2..N+Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

题目很水,裸的RMQ自然不必多说,对于每次询问输出区间最大值与最小值绝对值之差,不过要注意输入输出用cin cout会超时,只能用scanf printf,最终速度为1719ms

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

#define MAXN 50100

using namespace std;

int max(int a,int b)
{
    if(a>b) return a;
    return b;
}

int min(int a,int b)
{
    if(a<b) return a;
    return b;
}

int minRMQ[MAXN][18],maxRMQ[MAXN][18];

int getMinRMQ(int l,int r)
{
    int pos=(int)(log((r-l+1)*1.0)/log(2.0));
    return min(minRMQ[l][pos],minRMQ[r-(1<<pos)+1][pos]);
}

int getMaxRMQ(int l,int r)
{
    int pos=(int)(log((r-l+1)*1.0)/log(2.0));
    return max(maxRMQ[l][pos],maxRMQ[r-(1<<pos)+1][pos]);
}

int main()
{
    int n,m,q;
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&minRMQ[i][0]);
        maxRMQ[i][0]=minRMQ[i][0];
    }
    m=(int)(log(n*1.0)/log(2.0));
    for(int i=1;i<20;i++)
        for(int j=1;j<=n;j++)
        {
            if(j+(1<<i)-1<=n)
            {
                maxRMQ[j][i]=max(maxRMQ[j][i-1],maxRMQ[j+(1<<(i-1))][i-1]);
                minRMQ[j][i]=min(minRMQ[j][i-1],minRMQ[j+(1<<(i-1))][i-1]);
            }
        }
    for(int i=1;i<=q;i++)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        printf("%d\n",getMaxRMQ(a,b)-getMinRMQ(a,b));
    }
    return 0;
}



[POJ 3264]Balanced Lineup(ST算法求RMQ)

原文:http://blog.csdn.net/qpswwww/article/details/38826639

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!