首页 > 其他 > 详细

HDOJ 4821 String

时间:2014-08-28 02:05:28      阅读:233      评论:0      收藏:0      [点我收藏+]


字符串hash


String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 697    Accepted Submission(s): 190


Problem Description
Given a string S and two integers L and M, we consider a substring of S as “recoverable” if and only if
  (i) It is of length M*L;
  (ii) It can be constructed by concatenating M “diversified” substrings of S, where each of these substrings has length L; two strings are considered as “diversified” if they don’t have the same character for every position.

Two substrings of S are considered as “different” if they are cut from different part of S. For example, string "aa" has 3 different substrings "aa", "a" and "a".

Your task is to calculate the number of different “recoverable” substrings of S.
 

Input
The input contains multiple test cases, proceeding to the End of File.

The first line of each test case has two space-separated integers M and L.

The second ine of each test case has a string S, which consists of only lowercase letters.

The length of S is not larger than 10^5, and 1 ≤ M * L ≤ the length of S.
 

Output
For each test case, output the answer in a single line.
 

Sample Input
3 3 abcabcbcaabc
 

Sample Output
2
 

Source
 


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>

using namespace std;

typedef unsigned long long int ull;

const int maxn=100100;

int L,M;
char str[maxn];

ull xp[maxn],hash[maxn];
map<ull,int> ck;

void init()
{
	xp[0]=1;
	for(int i=1;i<maxn;i++)
		xp[i]=xp[i-1]*175;
}

ull get_hash(int i,int L)
{
	return hash[i]-hash[i+L]*xp[L];
}

int main()
{
	init();
    while(scanf("%d%d",&M,&L)!=EOF)
    {
        scanf("%s",str);
        int n=strlen(str);
        hash[n]=0;
        for(int i=n-1;i>=0;i--)
        {
        	hash[i]=hash[i+1]*175+(str[i]-'a'+1);
        }
        int ans=0;
        for(int i=0;i<L;i++)
        {
        	ck.clear();
        	int duan=0;
        	for(int j=0;i+(j+1)*L-1<n;j++)
        	{
        		/// i+j*L <---> i+(j+1)*L-1
        		duan++;
        		ull hahashsh=get_hash(i+j*L,L);
        		ck[hahashsh]++;
        		if(duan>=M)
        		{
        			if(duan>M)
        			{
	        			/// M+1 ago  : i+(j+1)*L-L*(M+1)
	        			ull Mago=get_hash(i+(j+1)*L-L*(M+1),L);
	        			if(ck[Mago])
	        			{
	        				ck[Mago]--;
	        				if(ck[Mago]==0) ck.erase(Mago);
	        			}
        			}
        			if(ck.size()==M) ans++;
        		}
        	}
        }
        printf("%d\n",ans);
    }
    return 0;
}



HDOJ 4821 String

原文:http://blog.csdn.net/ck_boss/article/details/38888341

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!