首页 > 其他 > 详细

UVA - 12293 Box Game (规律)

时间:2014-08-28 09:41:09      阅读:293      评论:0      收藏:0      [点我收藏+]

Description

bubuko.com,布布扣


  Box Game 

There are two identical boxes. One of them contains n balls, while the other box contains one ball. Alice and Bob invented a game with the boxes and balls, which is played as follows:

Alice and Bob moves alternatively, Alice moves first. For each move, the player finds out the box having fewer number of balls inside, and empties that box (the balls inside will be removed forever), and redistribute the balls in the other box. After the redistribution, each box should contain at least one ball. If a player cannot perform a valid move, he loses. A typical game is shown below:

bubuko.com,布布扣

When both boxes contain only one ball, Bob cannot do anything more, so Alice wins.


Question: if Alice and Bob are both clever enough, who will win? Suppose both of them are very smart and always follows a perfect strategy.

Input 

There will be at most 300 test cases. Each test case contains an integer n ( 2bubuko.com,布布扣nbubuko.com,布布扣109) in a single line. The input terminates by n = 0.

Output 

For each test case, print a single line, the name of the winner.

Sample Input 

2
3
4
0

Sample Output 

Alice
Bob
Alice
题意:有两个相同的盒子,其中一个盒子有n个球,另一个有1个球,每次把较小的那个数拿走,然后把较大的数分成两部分,使得操作后每个盒子至少有1个球,如果无法操作,
则当前游戏者输,判断先手(Alice)还是后手(Bob)胜
思路:可以通过SG定理打表找规律,也可以分析,假设当前为3的话,那么这个时候是先手输,然后有可能到达这个状态的有4,5,6,这些是先手胜的情况,那么7的话就是输啦,
依次类推下去,发现当n=2^k-1的时候,是Bob胜,其他的是Alice胜。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int sg[100], vis[100];

void init() {
	sg[1] = 0;
	sg[2] = 1;
	for (int i = 3; i < 100; i++) {
		memset(vis, 0, sizeof(vis));
		for (int j = (i+1)/2; j < i; j++)
			vis[sg[j]] = 1;
		for (int j = 0; ; j++)
			if (!vis[j]) {
				sg[i] = j;
				break;
			}
		printf("%d %d\n", i, sg[i]);
	}
}

int main() {
//	init();
	int n;
	while (scanf("%d", &n) != EOF && n) {
		if ((n & (n+1)) == 0)
			printf("Bob\n");
		else printf("Alice\n");
	}
	return 0;
}


UVA - 12293 Box Game (规律)

原文:http://blog.csdn.net/u011345136/article/details/38893327

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!