首页 > 其他 > 详细

Oil Deposits 新年特辑篇

时间:2020-01-23 13:17:47      阅读:90      评论:0      收藏:0      [点我收藏+]

 

链接:E - Oil Deposits

题目:

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2

翻译:给你一块地图 ,其中‘ @ ‘代表探测到有油的地方, 而‘ * ‘则是代表没有油的地方。
现在题目给出了油田的定义,所有连在一起的‘ @ ‘ 代表一个油田, 而连在一起的定义是有公共点或公共边。
而题目的要求是输出给你一张地图上的油田的个数。

思路:常规的搜索题,不过不再是4个方向,而是8个方向

搞下代码:
#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <queue>//能想到的头文件都写了 害怕错 
int dir[8][2]={{1,0},{1,1},{0,1},{-1,1},{-1,0},{-1,-1},{0,-1},{1,-1}};//坐标轴上的8个方向 
char mapp[105][105];
int n,m;
void dfs(int x,int y)//dfs 深度搜索  x为横 y为纵 
{
    if(mapp[x][y]==@)//将搜过的口袋标记 //如果为@ 则 标记为* 
        mapp[x][y]=*;
    for(int i=0;i<8;i++)//八个方向搜索 所以i为8 
    {
        int a=dir[i][0]+x;//横坐标改变
        int b=dir[i][1]+y;//纵坐标
        if(mapp[a][b]==@&&a<n&&a>=0&&b<m&&b>=0)//满足条件:是口袋且横纵坐标都在范围内 则进行搜索 
            dfs(a,b);
    }
}
int main()
{
    while(scanf("%d %d",&n,&m)&&n!=0&&m!=0)
    {
        int sum=0;//一开始设置为0 
        getchar();
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
                scanf("%c",&mapp[i][j]);
            getchar();
        }
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
        {
            if(mapp[i][j]==@)//遇到口袋进行搜索
            {
                dfs(i,j);
                sum++;//每次搜索完后 进行+1 
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

这道题的话dfs与bfs都可以,但这种题我觉得dfs显得更简单些(maybe)

顺便祝大家新年快乐。

 








Oil Deposits 新年特辑篇

原文:https://www.cnblogs.com/sidenynb/p/12230465.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!