首页 > 其他 > 详细

PAT Advanced 1096 Consecutive Factors (20分)

时间:2020-01-25 15:12:48      阅读:88      评论:0      收藏:0      [点我收藏+]

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630
 

Sample Output:

3
5*6*7

最大连乘因子,我们找的是最大连乘因子,所以,我们从2到sqrt(n)进行遍历,因为永远到不了sqrt(n),

之后进行遍历计算。

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
int main(){
    long int N, sqrt_n;
    cin >> N;
    sqrt_n = sqrt(N);
    vector<int> m, tmp_v;
    for(int i = 2; i <= sqrt_n; i++){
        int cp_i = i, sum = i;
        while(N % sum == 0 && cp_i <= sqrt_n){
            tmp_v.push_back(cp_i);
            cp_i++;
            sum *= cp_i;
        }
        if(tmp_v.size() > m.size())
            m = tmp_v;
        tmp_v.clear();
    }
    if(m.size() == 0) cout << 1 << endl << N;
    else {
        cout << m.size() << endl;
        for(int i = 0; i < m.size(); i++)
            if(i != m.size() - 1) cout << m[i] << "*";
            else cout << m[i];
    }
    system("pause");
    return 0;
}

 

PAT Advanced 1096 Consecutive Factors (20分)

原文:https://www.cnblogs.com/littlepage/p/12233061.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!