The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first.Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be “H(key) = key % TSize” where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.
Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 104. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space and are no more than 105.
Output Specification:
For each test case, in case it is impossible to insert some number, print in a line “X cannot be inserted.”where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.
Sample Input:
4 5 4
10 6 4 15 11
11 4 15 2
Sample Output:
15 cannot be inserted.
2.8
int step=0;
while(step<MS&&hash[(key+step*step)%MS]!=key&&hash[(key+step*step)%MS]!=0)step++; //二次探测
#include <iostream>
using namespace std;
bool isPrime(int num) {
if(num==1)return false;
for(int i=2; i*i<=num; i++) {
if(num%i==0)return false;
}
return true;
}
int main(int argc, char * argv[]) {
int MS,N,M,key;
scanf("%d %d %d",&MS,&N,&M);
while(!isPrime(MS))MS++; //size 若不是质数,重置为质数
int hash[MS]= {0};
for(int i=0; i<N; i++) {
scanf("%d",&key);
int step=0;
while(step<MS&&hash[(key+step*step)%MS]!=0)step++; //二次探测
if(step==MS)printf("%d cannot be inserted.\n", key); //不可插入
else hash[(key+step*step)%MS]=key; //可插入
}
double ans=0;
//第一个点测试错误,第一次遇到打印结果完全一样,但是不通过的情况
for(int i=0; i<M; i++) {
scanf("%d", &key);
int step=0;
while(step<MS&&hash[(key+step*step)%MS]!=key&&hash[(key+step*step)%MS]!=0)step++; //二次探测
ans+=(step+1); //如果hash(key)正好命中,比较次数为0+1;如果需要二次探测,比较次数=step+1;如果是二次探测找不到的情况,比较次数=MS+1与临界step=MS-1时探测到的情况做区分
}
printf("%.1f", ans/(M*1.0));
return 0;
}
PAT Advanced 1145 Hashing – Average Search Time (25) [哈希映射,哈希表,平?探测法]
原文:https://www.cnblogs.com/houzm/p/12242218.html