首页 > 其他 > 详细

A1027 Colors in Mars (20分)

时间:2020-02-25 02:33:21      阅读:53      评论:0      收藏:0      [点我收藏+]

1027 Colors in Mars (20分)

首先,先贴柳神的博客

https://www.liuchuo.net/ 这是地址

想要刷好PTA,强烈推荐柳神的博客,和算法笔记

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71  

Sample Output:

#123456

题目大意

就是换进制,3个十进制的,转换为13进制 10,11,12 用A,B,C代替

每个数字都要输出两位,不足的用0补齐

代码如下

#include<iostream>
#include<cmath>
using namespace std;
int main(void) {
    int Red[3];
    char r[7] = {'0'};
    for (int i = 0; i < 7; i++) {
        r[i] = '0';
    }
    cin >> Red[0] >> Red[1] >> Red[2];
    for (int i = 0; i < 3; i++) {
        while (Red[i]) {
            if (Red[i] % 13 >= 10) {
                r[i * 2 + 1] = Red[i] % 13+55;
            }
            else {
                r[i * 2 + 1] = Red[i] % 13 + 48;
            }
            Red[i] /= 13;
            if (Red[i] % 13 >= 10) {
                r[i * 2] = Red[i] % 13 + 55;
            }
            else {
                r[i * 2] = Red[i] % 13 + 48;
            }
            Red[i] /= 13;

        }
    }
    printf("#");
    for (int i = 0; i < 6; i++) {
        printf("%c", r[i]);
    }
    return 0;
}

A1027 Colors in Mars (20分)

原文:https://www.cnblogs.com/a-small-Trainee/p/12359703.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!