首页 > 其他 > 详细

安装RabbitMQ,一直提示Erlang版本过低

时间:2020-02-27 20:55:29      阅读:30      评论:0      收藏:0      [点我收藏+]

标签:rabbitmq   src   技术   找到   查找进程   进程   

1.背景

windows系统,控制面板卸载Erlang后,重新安装Erlang成功,当再安装RabbitMQ时,报如下提示:

技术分享图片

意思就是说Erlang版本过低,请安装更高的版本。

出现上面问题的原因,是卸载Erlang方式不对,没有清理干净导致。

2.解决

RabbitMq和Erlang版本对应关系,请见官网 https://www.rabbitmq.com/which-erlang.html

按照网上说明,卸载RabbitMq和Erlang

(1)打开Windows控制面板,双击“程序和功能”。

(2)在当前安装的程序列表中,右键单击RabbitMQ Server,然后单击“卸载”。

(3)在当前安装的程序列表中,右键单击“Erlang OTP”,然后单击“卸载”。

(4)打开Windows任务管理器。

(5)在任务管理器中,查找进程epmd.exe。 如果此进程仍在运行,请右键单击该进程,然后单击“结束进程”。

(6)删除RabbitMQ和Erlang的所有安装目录。

(7)删除文件C:\Windows\System32\config\systemprofile\.erlang.cookie(如果存在)。

(8)转到用户文件夹:C:\ Users \ [username],然后删除文件.erlang.cookie。删除

(9)同样在User文件夹中,转到AppData \ Roaming \ RabbitMQ。删除RabbitMQ文件夹。

(10)删除注册表HKEY_LOCAL_MACHINE\SOFTWARE\Ericsson\Erlang\ErlSrv的子项。

(11)打开运行cmd->sc delete RabbitMQ。

(12)打开运行->regedit 找到RabbitMQ节点,删掉即可。

再安装RabbitMQ时,还是提示Erlang版本过低。

输入regedit,打开注册表,将图中红色圈出的旧版本(6.2)删掉即可。

技术分享图片

 

安装RabbitMQ,一直提示Erlang版本过低

标签:rabbitmq   src   技术   找到   查找进程   进程   

原文:https://www.cnblogs.com/lwcode6/p/12374183.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号