首页 > 其他 > 详细

PTA甲级1037 Magic Coupon (25分)

时间:2020-03-25 21:55:57      阅读:58      评论:0      收藏:0      [点我收藏+]

首先,先贴柳神的博客

https://www.liuchuo.net/ 这是地址

想要刷好PTA,强烈推荐柳神的博客,和算法笔记

题目原文

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N‘s!

For example, given a set of coupons { 1 2 4 ?1 }, and a set of product values { 7 6 ?2 ?3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N**C, followed by a line with N**C coupon integers. Then the next line contains the number of products N**P, followed by a line with N**P product values. Here 1≤N**C,N**P≤105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

生词如下

Coupon 券

bonus 奖金

题目大意

就是有N个折扣卷,有正有负,还有K个产品,每个产品的价格也不同

折扣卷的规则是,两个相乘的积,就是你可以拿到的钱,每个卷子和产品只能用一次,但是可以不用

思路如下:

把每个折扣卷子,都设立一个bool judge来表明他们用了还是没有用,在简单排下序,最大的正数和最大的正数相乘,最小的负数和最小的负数相乘,然后推,第二个大的正数和第二个大的正数想乘,出现了两个数字异号的情况就退出

代码如下

#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
struct node {
	double Num;
	bool Judge = true;
};
bool cmp(node a, node b) { return a.Num > b.Num; }
int main(void) {
	int NCoupon,NProduct;
	scanf("%d", &NCoupon);
	vector<node>Coupon(NCoupon);
	for (int i = 0; i < NCoupon; i++)	scanf("%lf", &Coupon[i].Num);
	sort(Coupon.begin(), Coupon.end(), cmp);
	scanf("%d", &NProduct);
	vector<node>Product(NProduct);
	for (int i = 0; i < NProduct; i++)	scanf("%lf", &Product[i].Num);
	sort(Product.begin(), Product.end(), cmp);
	int J=0;	//这个是产品的标号
	double Sum = 0.0;
	//先寻找大家都是正的情况
	for (int i = 0; i < NCoupon; i++) {
		if (Coupon[i].Num > 0&&Coupon[i].Judge) {
			if (Product[J].Num > 0&& Product[J].Judge) {
				Sum += Coupon[i].Num * Product[J].Num;
				Product[J].Judge = false;
				Coupon[i].Judge = false;
				J++;
			}else{
				break;
			}
		}
	}
	//在寻找大家都是负的情况
	J = NProduct-1;
	for (int i = NCoupon-1; i >0; i--) {
		if (Coupon[i].Num <0 && Coupon[i].Judge) {
			if (Product[J].Num < 0 && Product[J].Judge) {
				Sum += Coupon[i].Num * Product[J].Num;
				Product[J].Judge = false;
				Coupon[i].Judge = false;
				J--;
			}
			else {
				break;
			}
		}
	}
	printf("%.0lf", Sum);
	return 0;
}

PTA甲级1037 Magic Coupon (25分)

原文:https://www.cnblogs.com/a-small-Trainee/p/12570609.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!