首页 > 其他 > 详细

2058 The sum problem

时间:2020-03-27 14:56:48      阅读:63      评论:0      收藏:0      [点我收藏+]
Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
 
Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
 
Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
 
Sample Input
20 10 50 30 0 0
 
Sample Output
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
 

 参考链接:The sum problem

最终AC代码:

#include <cstdio>
#include <cmath>
//难点一:想到用等差数据求和的思想;难点二:从长度求首项,而不是从首项求长度思想 
int main(){
    int i, k, n, m;
    while(scanf("%d %d", &n, &m) != EOF){
        if(n==0 && m==0) break;
        for(k=sqrt(2*m); k>0; k--){ //k是区间的长度 
            i = (2*m - k*(k-1)) / (2*k); //i表示首项 
            if(k*i+k*(k-1)/2 == m){ //找到满足条件的区间 
                printf("[%d,%d]\n", i, i+k-1);
            }
        }
        printf("\n");
    }
    return 0;
}

2058 The sum problem

原文:https://www.cnblogs.com/heyour/p/12581345.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!