首页 > 其他 > 详细

HDoj 2052 Picture

时间:2020-04-12 00:26:55      阅读:80      评论:0      收藏:0      [点我收藏+]
Problem Description
Give you the width and height of the rectangle,darw it.
 

 

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 

 

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
 

 

Sample Input
3 2
 

 

Sample Output
+---+ | | | | +---+
 

 

Author
xhd
 

 

Source
 

 

Recommend
linle   |   We have carefully selected several similar problems for you:  2054 2072 2053 2055 2056 
 
 
 
C语言代码如下:
#include<stdio.h>
int main()
{
    int x,y;
    while(scanf("%d%d",&x,&y)!=EOF)
    {
        x+=2;
        y+=2;

        for(int i=0;i<y;i++)
        {
            for(int j=0;j<x;j++)
            {
                if((i==0&&j==0) ||(i==0&&j==x-1)||(i==y-1&&j==0)||(i==y-1&&j==x-1))
                    printf("+");
                else if(i==0||i==y-1)
                    printf("-");
                else if(j==0||j==x-1)
                    printf("|");
                else
                    printf(" ");
            }
            printf("\n");
        }
        printf("\n");
    }
}

 

HDoj 2052 Picture

原文:https://www.cnblogs.com/wzmm/p/12683032.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!