首页 > 其他 > 详细

HDoj 2058 The sum problem

时间:2020-04-16 23:04:57      阅读:56      评论:0      收藏:0      [点我收藏+]
Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
 

 

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
 

 

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
 

 

Sample Input
20 10 50 30 0 0
 

 

Sample Output
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
 

 

Author
8600
 

 

Source
 

 

Recommend
linle   |   We have carefully selected several similar problems for you:  2059 2062 2060 2072 2061 
 
 
 
 
 
如果按照题意暴力,会超时
根据前n项和公式 Sn = na?   + n(n-1)/2;
na? = Sn - n(n-1)/2 ;
此时假设已知前n项和为m,则
na? = m - n(n-1)/2 ;
a? =( m - n(n-1)/2  ) / n ;
如果 m - n(n-1)/2 可以被n整除,那么初项 a?就可以求得出来,子序列末项是 a? + n - 1;
 
要注意,如果n从输入的N开始遍历到1仍然会超时
有题目可知: m - n(n-1)/2   >0
可推出  n <√2m
从 √2m 开始遍历,这样就不会超时
 
C语言代码如下:
#include<stdio.h>
#include<math.h>
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
            break;
        for(int i=sqrt(2*m);i>=1;i--)
        {
            int na1=m- (i*(i-1)/2);
            if( na1%i == 0 )
                printf("[%d,%d]\n",na1/i,na1/i+i-1);
        }
        printf("\n");
    }
}

 

 
 

HDoj 2058 The sum problem

原文:https://www.cnblogs.com/wzmm/p/12715915.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!