首页 > 其他 > 详细

#2054:A == B ?(水题坑人)

时间:2020-04-23 21:41:37      阅读:472      评论:0      收藏:0      [点我收藏+]

Problem Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

Input

each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

Sample Input

1 2
2 2
3 3
4 3

Sample Output

NO
YES
YES
NO

思路:

此题关键是找小数点,找到小数点把最后面无效的零去掉再比较就OK

教训:

一开始做的时候感觉好简单啊,直接string输入然后==比较,然后WA打脸了,发觉可能是大数比较问题,然后long double测试还是没过,想了很久才想到可能是精度问题如000123 和 123 还有小数点 ‘ . ‘的问题一些的,不断完善最后才AC了

AC代码

#include<bits/stdc++.h>
using namespace std;
void trim0(string& b)
{
	int len = b.length();
	if(b.find(‘.‘)!=string::npos)
	{
		for(int i=len-1;b[i]==‘0‘;i--)
			len--;
		b=b.substr(0,len);
	}
	if(b[len-1]==‘.‘)
		b=b.substr(0,len-1);
}
void main()
{
	string a,b;
	while(cin>>a>>b)
	{
		trim0(a);
		trim0(b);
		if(a==b)
			cout<<"YES"<<endl;
		else
			cout<<"NO"<<endl;
	}
}

#2054:A == B ?(水题坑人)

原文:https://www.cnblogs.com/RioTian/p/12763643.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!