首页 > 其他 > 详细

3n+1问题

时间:2020-05-12 22:32:37      阅读:55      评论:0      收藏:0      [点我收藏+]

题目:

猜想:对于任意大于1的自然数n,若n为奇数,则将n变为3n+1,否则变为n的一半。

经过若干次这样的变换,一定会使n变为1。例如,3->10->5->16->8->4->2->1。

输入n,输出变换的次数。n<=10^9。

样例输入:

3

样例输出:

7

 

程序一

如下:

#include<stdio.h>
int main()
{
    int n, count = 0;
    scanf("%d",&n);
    while(n>1)
    {
        if(n%2 == 1) n = n*3 +1;
        else n/=2;
        count++;
        printf("%d\t",n);
    }
    printf("\n\n");
    printf("%d\n",count);
    return 0;
} 
//当输入987654321时,会发生溢出
//导致打印 1次 

 

不要忘记测试。一个看上去正确的程序可能隐含错误。

c99中并没有规定int类型的确切大小,int一般都是32为整数,范围是-2147483648 ~ 2147483647

 

程序2

程序2给出的版本是long long 版本的代码它避开了对long long的输入输出,并且成功算出 n = 987654321 时的答案为180。

#include<stdio.h> 
int main()
{
    int n2 , count =0;
    scanf("%d",&n2);
    long long n = n2;
    while(n>1)
    {
        if(n%2 ==1) n = n*3+1;
        else n/=2;
        count++; 
        printf("%d -> ",n);
    } 
    printf("\n\n");
    printf("%d\n",count);
    return 0;
}

 

3n+1问题

原文:https://www.cnblogs.com/Vincent-yuan/p/12879194.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!