首页 > 其他 > 详细

Time类的定义(成员函数)

时间:2014-09-11 23:59:22      阅读:679      评论:0      收藏:0      [点我收藏+]

2-2 Time类的定义

Time Limit: 1000MS Memory limit: 65536K

题目描述

通过本题目的练习可以掌握类与对象的定义;

设计一个时间类Time,私有数据成员有hour()minute()second()

公有成员函数有:setHour(int)设置数据成员hour的值,非法的输入默认为12setMinue(int)设置数据成员minute的值,非法输入默认为0setSecond(int)设置数据成员second的值,非法输入默认为0setTime(intintint)设置时、分、秒三个数据成员的值; showTime()显示时间对象的值。

在主函数main()中调用相应成员函数,使得时间对象的值能从键盘接收,并正确显示。

输入

 

输入3个整数,用一个空格间隔

输出

 

输出 时、分、秒的值,中间用“:”间隔

示例输入

10 11 12

示例输出

10:11:12
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <iostream>
#include <vector>
#include <stack>
using namespace std;
class Time
{
private:
	int h,m,s;
public:
	void setHour()
    {
	 if(h>12||h<0)
		h=12;
    }
    void setMin()
    {
    	if(m>60||m<0)
		m=0;
    }
    void setSec()
    {
    	if(s<0||s>60)
			s=0;
    }
    void setTime()
    {
    	cin>>h>>m>>s;
    }
    void showTime()
{
	if (h<10)
		cout<<"0";
	cout<<h<<":";
	if (m<10)
	cout<<"0";
	cout<<m<<":";
	if (s<10)
		cout<<"0";
	cout<<s<<endl;
}

};
int main()
{
	class Time xx;
	xx.setTime();
	xx.setHour();
	xx.setMin();
	xx.setSec();
	xx.showTime();
	return 0;
}


Time类的定义(成员函数)

原文:http://blog.csdn.net/qq_16255321/article/details/39213121

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!