题目
About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people‘s talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one‘s virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.
Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang‘s theory.
Input Specification:
Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤10^?5
), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".
Then N lines follow, each gives the information of a person in the format:
ID_Number Virtue_Grade Talent_Grade
where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.
Output Specification:
The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID‘s.
Sample Input:
14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60
Sample Output:
12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90
题目更好的阅读体验:点这!!!
题意:有五类人。
类别越高,排在越前,类别相同,总成绩越高则排在越前,总成绩依然相同则德分越高则越靠前,若德分依然相同,则准考证号越小越靠前。
解题思路:将每一类人做一个标记,然后写一个compare的函数,依次按上面的解析进行比较即可,这道题感觉就是模拟 + 排序,题意需要进行整理一下。还有就是边界的问题,看清题意是不低于还是低于就ok。
AC代码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<stdlib.h>
#include<string.h>
#include<math.h>
using namespace std;
const int maxn = 1e5 + 7;
int n, m, l, h, cnt = 0;
struct grade
{
int id; //ID_Number
int v, t; //Virtue_Grade Talent_Grade
int sum; //Sum_Grade
int classes;
}a[maxn];
bool cmp(grade b, grade c)
{
if(b.classes != c.classes)
return b.classes < c.classes;
else if(b.sum != c.sum)
return b.sum > c.sum;
else if(b.v != c.v)
return b.v > c.v;
else return b.id < c.id;
}
int main()
{
ios::sync_with_stdio(false);
cin >> n >> l >> h;
for(int i = 1; i <= n; i++)
{
cin >> a[i].id >> a[i].v >> a[i].t;
a[i].sum = a[i].v + a[i].t;
if(a[i].v < l || a[i].t < l)
{
a[i].classes = 5;
cnt ++;
}
else if(a[i].v >= h && a[i].t >= h)
a[i].classes = 1;
else if(a[i].v >= h && a[i].t < h)
a[i].classes = 2;
else if(a[i].v < h && a[i].t < h && a[i].v >= a[i].t)
a[i].classes = 3;
else a[i].classes = 4;
}
sort(a + 1, a + 1 + n, cmp);
m = n - cnt;
cout << m << endl;
for(int i = 1; i <= m; i++)
cout << a[i].id << " " << a[i].v << " " << a[i].t << endl;
return 0;
}
PAT(甲级) -- 1062 Talent and Virtue
原文:https://www.cnblogs.com/K2MnO4/p/13280120.html