首页 > 其他 > 详细

HDU - 5011 Game

时间:2014-09-14 23:42:04      阅读:413      评论:0      收藏:0      [点我收藏+]

Problem Description
Here is a game for two players. The rule of the game is described below:

● In the beginning of the game, there are a lot of piles of beads.

● Players take turns to play. Each turn, player choose a pile i and remove some (at least one) beads from it. Then he could do nothing or split pile i into two piles with a beads and b beads.(a,b > 0 and a + b equals to the number of beads of pile i after removing)

● If after a player‘s turn, there is no beads left, the player is the winner.

Suppose that the two players are all very clever and they will use optimal game strategies. Your job is to tell whether the player who plays first can win the game.
 

Input
There are multiple test cases. Please process till EOF.

For each test case, the first line contains a postive integer n(n < 105) means there are n piles of beads. The next line contains n postive integer, the i-th postive integer ai(ai < 231) means there are ai beads in the i-th pile.
 

Output
For each test case, if the first player can win the game, ouput "Win" and if he can‘t, ouput "Lose"
 

Sample Input
1 1 2 1 1 3 1 2 3
 

Sample Output
Win Lose Lose 题意:简单的Nimi游戏 思路:异或起来0为先手输
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef __int64 ll;
using namespace std;

int main() {
	int n;
	while (scanf("%d", &n) != EOF) {
		ll ans = 0;
		ll tmp;
		for (int i = 0; i < n; i++) {
			scanf("%I64d", &tmp);
			ans ^= tmp;
		}
		if (ans == 0)
			printf("Lose\n");
		else printf("Win\n");
	} 	
}


HDU - 5011 Game

原文:http://blog.csdn.net/u011345136/article/details/39275819

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!