找规律
Number Sequence
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 303 Accepted Submission(s): 149
Special Judge
Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:
● ai ∈ [0,n]
● ai ≠ aj( i ≠ j )
For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):
t = (a0 ⊕ b0) + (a1 ⊕ b1) +···+ (an ⊕ bn)
(sequence B should also satisfy the rules described above)
Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
Input
There are multiple test cases. Please process till EOF.
For each case, the first line contains an integer n(1 ≤ n ≤ 105), The second line contains a0,a1,a2,...,an.
Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b0,b1,b2,...,bn. There is exactly one space between bi and bi+1(0
≤ i ≤ n - 1). Don’t ouput any spaces after bn.
Sample Input
Sample Output
Source
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int n,a[100100],sig[100100];
long long int ans;
int wei(int x)
{
if(x==0) return 0;
return log(x*1.)/log(2.0);
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
ans=0;
memset(sig,-1,sizeof(sig));
for(int i=n;i>=0;i--)
{
if(n%2==0&&i==0)
{
sig[0]=0;
continue;
}
if(sig[i]!=-1)
{
ans+=i^sig[i];
continue;
}
int w=wei(i);
w++;
int fan=((1<<w)-1)^i;
sig[i]=fan;
sig[fan]=i;
ans+=i^sig[i];
}
printf("%I64d\n",ans);
for(int i=0;i<=n;i++)
{
int x;
scanf("%d",&x);
if(i) putchar(32);
printf("%d",sig[x]);
}
putchar(10);
}
return 0;
}
HDOJ 5014 Number Sequence
原文:http://blog.csdn.net/ck_boss/article/details/39276653