首页 > 其他 > 详细

HDU 1977 Consecutive sum II(数学)

时间:2014-09-16 20:38:31      阅读:465      评论:0      收藏:0      [点我收藏+]

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1977


Problem Description
Consecutive sum come again. Are you ready? Go ~~
1    = 0 + 1
2+3+4    = 1 + 8
5+6+7+8+9  = 8 + 27

You can see the consecutive sum can be representing like that. The nth line will have 2*n+1 consecutive numbers on the left, the first number on the right equal with the second number in last line, and the sum of left numbers equal with two number’s sum on the right.
Your task is that tell me the right numbers in the nth line.
 
Input
The first integer is T, and T lines will follow.
Each line will contain an integer N (0 <= N <= 2100000).
 
Output
For each case, output the right numbers in the Nth line.
All answer in the range of signed 64-bits integer.
 
Sample Input
3 0 1 2
 
Sample Output
0 1 1 8 8 27
 
Author
Wiskey
 
Source


PS:

找到规律就OK啦2333333333!

代码如下:

#include <cstdio>
int main()
{
    int t;
    __int64 n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        printf("%I64d %I64d\n",n*n*n,(n+1)*(n+1)*(n+1));
    }
    return 0;
}


HDU 1977 Consecutive sum II(数学)

原文:http://blog.csdn.net/u012860063/article/details/39322327

(1)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!