Number Sequence
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 713 Accepted Submission(s): 337
Special Judge
Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:
● ai ∈ [0,n]
● ai ≠ aj( i ≠ j )
For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):
t = (a0 ⊕ b0) + (a1 ⊕ b1) +···+ (an ⊕ bn)
(sequence B should also satisfy the rules described above)
Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
Input
There are multiple test cases. Please process till EOF.
For each case, the first line contains an integer n(1 ≤ n ≤ 105), The second line contains a0,a1,a2,...,an.
Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b0,b1,b2,...,bn. There is exactly one space between bi and bi+1(0
≤ i ≤ n - 1). Don’t ouput any spaces after bn.
Sample Input
Sample Output
Source
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#include<vector>
#include<cmath>
#include<string>
#include<queue>
#define eps 1e-9
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;
const int maxn=100000+10;
int a[maxn],n,ans[maxn];
bool vis[maxn];
int gao(int k)
{
int cnt=0;
while(k)
{
k>>=1;
cnt++;
}
return cnt;
}
int main()
{
while(~scanf("%d",&n))
{
memset(vis,false,sizeof(vis));
for(int i=0;i<=n;i++)
scanf("%d",&a[i]);
for(int i=n;i>=0;i--)
{
if(vis[i]) continue;
int move=gao(i);
int temp=(((1<<move)-1)^i);//找到和i二进制表示互补的数
ans[temp]=i;
ans[i]=temp;
vis[i]=vis[temp]=true;
}
ll sum=0;
for(int i=0;i<=n;i++)
sum+=i^ans[i];
printf("%I64d\n",sum);
for(int i=0;i<=n;i++)
{
if(i==n)
printf("%d\n",ans[a[i]]);
else
printf("%d ",ans[a[i]]);
}
}
return 0;
}