首页 > 其他 > 详细

安迪的第一个字典(Andy's First Dictionary , UVa 10815)

时间:2020-12-15 00:03:19      阅读:32      评论:0      收藏:0      [点我收藏+]

输入一个文本,找出所有不同的单词(连续的字母序列),按字典序从小到大输出。

单词不区分大小写。

样例输入:

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the road.

The sign read: "Disneyland Left."

So they went home.

样例输出(为了节省篇幅只保留前5行):

a

adventures

blondes

came

disneyland

 

分析:由于string 已经定义了小于运算符,直接使用set保存单词集合即可

注意,输入时把所有非字母的字符变成空格,然后利用stringstream得到各个单词

代码如下

#include<iostream>
#include<string>
#include<set>
#include<sstream>
using namespace std;

set<string> dict;//string集合

int main(){
    string s,buf;
    while(cin>>s){
        for(int i=0;i<s.length();i++){
            if(isalpha(s[i])){
                s[i] = tolower(s[i]);
            }else{
                s[i]= ;
            }
        }
        stringstream ss(s);
        while(ss >> buf) dict.insert(buf); //插入到set中后就已经有序了
    }
    for(set<string>::iterator it = dict.begin();it != dict.end(); ++it){
        cout<< *it <<"\n";
    }
    return 0;
} 

 

安迪的第一个字典(Andy's First Dictionary , UVa 10815)

原文:https://www.cnblogs.com/Vincent-yuan/p/14135834.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!