首页 > 其他 > 详细

hd1064 Financial Management

时间:2021-01-17 19:57:49      阅读:35      评论:0      收藏:0      [点我收藏+]

Financial Management

hdu1064

题目

Problem Description
Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
Input
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
Output
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
Sample Input
100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75
Sample Output
$1581.42

题目大意:

拉里毕业后赚了很多钱,觉得不够,他决定投资。计算过去12个月平均账户余额。

解题思路

先对每月账户余额求和,然后再算平均余额。

注意输出格式。

代码

#include <iostream>
#include <cstring>

using namespace std;

int main()
{
    float closing[12];
    float sum;
    for(int i = 0; i < 12; i++)
    {
        cin >> closing[i];
        sum += closing[i];
    }
    float aver = sum/12.0;
    cout << ‘$‘ << aver << endl;
    return 0;
}

hd1064 Financial Management

原文:https://www.cnblogs.com/Jernewson/p/14289472.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!