首页 > 其他 > 详细

Hangman Judge UVA - 489

时间:2021-01-30 21:17:55      阅读:35      评论:0      收藏:0      [点我收藏+]

?In “Hangman Judge,” you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

  1. The contestant tries to solve to puzzle by guessing one letter at a time.
  2. Every time a guess is correct, all the characters in the word that match the guess will be “turned over.” For example, if your guess is ‘o’ and the word is “book”, then both ‘o’s in the solution will be counted as “solved”.
  3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.
  4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
  5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
  6. . If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

?Your task as the “Hangman Judge” is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

?Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of ‘-1’ would indicate the end of all games (and input).

Output

?The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.

You lose.

You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.

HINT

?? 这个题需要注意的地方是需要对要猜的的单词进行字母去重。我的思路是,输入标准的单词之后,对单词进行去重,并求出字母的数量。然后再函数里面递归判断猜的字母。

Accepted

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int wa = 0;					//错误次数
int wordsum = 0;			//字母总数
int flag = 0;				//判断状态

void guess(int* s)
{
	char ch;
	ch = getchar();
	if (ch != ‘\n‘)
	{
		if (s[ch - ‘a‘])
		{
			wordsum--;
			s[ch - ‘a‘] = 0;
		}
		else wa++;
		if (wa == 7)
		{
			while (ch != ‘\n‘)ch=getchar();
			flag = 1;
		}
		else if (!wordsum)
		{
			while (ch != ‘\n‘)ch=getchar();
			flag = 2;
		}	
		else guess(s);
	}
	else if (ch == ‘\n‘)
		flag = 0;
	return;
}

int main()
{
	int num;
	char arr[100];
	while (1)
	{
		wa = 0;
		int s[30] = { 0 };
		wordsum = 0;
		flag = 0;
		scanf("%d",&num);
		if (num == -1)break;
		scanf("%s", arr);
		int len = strlen(arr);
		for (int i = 0;i < len;i++)
		{
			if (!s[arr[i] - ‘a‘])wordsum++;
			s[arr[i] - ‘a‘] = 1;
		}
		getchar();
		guess(s);
		printf("Round %d\n", num);
		if (flag == 0)printf("You chickened out.\n");
		else if (flag == 1)printf("You lose.\n");
		else if (flag = 2)printf("You win.\n");
	}


}

Hangman Judge UVA - 489

原文:https://www.cnblogs.com/3236676588buladuo/p/14350264.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!