首页 > 其他 > 详细

1001. A+B Format (20) ——PAT (Advanced Level) Practise

时间:2014-09-23 19:02:56      阅读:250      评论:0      收藏:0      [点我收藏+]

题目信息:


1001. A+B Format (20)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

代码如下:

#include <stdio.h>
int main()
{
	int a, b;
	char arr[30], flag;
	arr[29] = '\0';
	while (scanf("%d%d", &a, &b) != EOF)
	{
		int k = 29;
		int s = a + b, t = 0;
		flag = 0;
		if (s < 0)
		{
			flag = 1;
			s *= -1;
		}
		if (s == 0)
			arr[--k] = '0';
		while (s)
		{
			arr[--k] =  '0' + s % 10;
			if (++t == 3)
			{
				t = 0;
				if (s >= 10)
					arr[--k] = ',';
			}
			s /= 10;
		}
		if (flag)
			arr[--k] = '-';
		printf("%s\n", arr + k);
	}
	return 0;
}


1001. A+B Format (20) ——PAT (Advanced Level) Practise

原文:http://blog.csdn.net/xianyun2009/article/details/39500843

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!