首页 > 其他 > 详细

1001 A+B Format (20 分)

时间:2021-08-20 09:12:43      阅读:23      评论:0      收藏:0      [点我收藏+]

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where ?106a,b106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 

#include<iostream>
using namespace std;
int main()
{
    int  A,B;
    cin >> A >> B;
    int C = A + B;
    string num = to_string(C);
    string res;
    
    for(int i = num.size() - 1 , j = 0 ; i >= 0 ; i-- ){
        res = num[i] + res ;
        j++;
        if( j % 3 == 0 && i && num[i - 1] != ‘-‘)
            res = ‘,‘ + res;
    }
    cout << res ;
    return 0;
}

1001 A+B Format (20 分)

原文:https://www.cnblogs.com/yztozju/p/15164640.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!