首页 > 系统服务 > 详细

-bash: /usr/local/bin/rar: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

时间:2022-05-27 21:30:59      阅读:5      评论:0      收藏:0      [点我收藏+]

 

1、问题

[root@PC3 test6]# rar x xiaohou.rar
-bash: /usr/local/bin/rar: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

 

2、

[root@PC3 test6]# yum install glibc.i686
Loaded plugins: langpacks, product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package glibc.i686 0:2.17-55.el7 will be installed
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-55.el7.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-55.el7.i686
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.15.4-2.el7 will be installed
--> Finished Dependency Resolution
…………
Installed:
  glibc.i686 0:2.17-55.el7

Dependency Installed:
  nss-softokn-freebl.i686 0:3.15.4-2.el7

Complete!

 

3、

[root@PC3 test6]# rar x xiaohou.rar
rar: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

 

4、

[root@PC3 test6]# yum install libstdc++.so.6
Loaded plugins: langpacks, product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package libstdc++.i686 0:4.8.2-16.el7 will be installed
--> Processing Dependency: libgcc_s.so.1 for package: libstdc++-4.8.2-16.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: libstdc++-4.8.2-16.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.3) for package: libstdc++-4.8.2-16.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_4.2.0) for package: libstdc++-4.8.2-16.el7.i686
--> Processing Dependency: libgcc_s.so.1(GLIBC_2.0) for package: libstdc++-4.8.2-16.el7.i686
--> Running transaction check
…………
Installed:
  libstdc++.i686 0:4.8.2-16.el7

Dependency Installed:
  libgcc.i686 0:4.8.2-16.el7

Complete!

 

5、

 

-bash: /usr/local/bin/rar: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

原文:https://www.cnblogs.com/liujiaxin2018/p/15350434.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!