首页 > 其他 > 详细

A Multiplication Game

时间:2014-09-26 22:45:59      阅读:506      评论:0      收藏:0      [点我收藏+]

A Multiplication Game

http://acm.hdu.edu.cn/showproblem.php?pid=1517

 

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3761    Accepted Submission(s): 2136


Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

 

Input
Each line of input contains one integer number n.
 

 

Output
For each line of input output one line either

Stan wins.

or

Ollie wins.

assuming that both of them play perfectly.
 

 

Sample Input
162 17 34012226
 

 

Sample Output
Stan wins. Ollie wins. Stan wins.
 
 
 
 
bubuko.com,布布扣
#include<stdio.h>
int main()
{
  double n;
  while(scanf("%lf",&n)!=EOF)
  {
     while(n>18) n/=18;
     printf(n<=9?"Stan wins.\n":"Ollie wins.\n");
  }
  return 0;
}
View Code

 

 

 

 

A Multiplication Game

原文:http://www.cnblogs.com/M-D-LUFFI/p/3995673.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!