首页 > 其他 > 详细

hdu 4405(概率dp简单题)

时间:2014-10-13 23:05:18      阅读:592      评论:0      收藏:0      [点我收藏+]

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4405

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1535    Accepted Submission(s): 1050


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases.
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0.
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
1.1667 2.3441
 

Source
 思路:用dp[i]表示从i这点出发到游戏结束的 expect 步数,
那么容易知道状态转移方程式:
p表示概率;
dp[i]=p*dp[i+1]+p*dp[i+2]+p*dp[i+3]+p*dp[i+4]+p*dp[i+5]+p*dp[i+6]+1;
#include <iostream>
#include <string.h>
#include <string>
#include <cstdio>
#include <algorithm>
#include <map>
const int N=1e5+100;
using namespace std;
double dp[N];

int main()
{
    int n,m;
    map<int ,int >mp;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
      if(n==0&&m==0)break;
      mp.clear();
      memset(dp,0,sizeof(dp));
      for(int i=0;i<m;i++)
      {
        int a,b;
        cin>>a>>b;
        mp[a]=b;
      }
      double p=1.0/6;
      for(int i=n;i>=0;i--)
      {
        if(i==n)continue;
        if(mp[i])
          dp[i]=dp[mp[i]];
        else
        dp[i]=p*dp[i+1]+p*dp[i+2]+p*dp[i+3]+p*dp[i+4]+p*dp[i+5]+p*dp[i+6]+1;
      }
     printf("%.4lf\n",dp[0]);
    }
    return 0;
}


hdu 4405(概率dp简单题)

原文:http://blog.csdn.net/liusuangeng/article/details/40049707

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!