首页 > 其他 > 详细

POJ 1026 Cipher 密码问题

时间:2014-02-22 08:51:45      阅读:250      评论:0      收藏:0      [点我收藏+]

Cipher
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 18779   Accepted: 4999

Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message. 

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n. 

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages. 

Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output

BolHeol  b
C RCE

Source


给一个字符串加密,如果字符串长度不够n,那么对字符串补空格,一直到n。给你n个数字代表加密方式,i位置的字母将被写到加密信息的ai位置,如此反复加密k次,让你求最后的密文。
如果k很大的话,直接模拟肯定不行。那么只要找到每个数字的循环周期就可以了,例如给出的样例,1->4->7->1即循环了三次,2->5->2循环了两次。每个数字都能求出它的周期,最后对每个数字的循环节取模置换就是答案。
//540K	47MS
#include<stdio.h>
#include<string.h>
#define M 207
int s[M],cycle[M],path[M][M];//cycle存周期,path存路径
char z[M*10],ans[M*10];
int n;
void getloop()
{
    memset(cycle,0,sizeof(cycle));
    for(int i=0;i<n;i++)//求每一个数的周期
    {
        int j=i;
        cycle[i]=1;
        path[i][0]=j;
        for(j=s[j];j!=i;j=s[j])
            path[i][cycle[i]++]=j;
    }
}
int main()
{
    while(scanf("%d",&n),n)
    {
        int key,m,i;
        for(i=0;i<n;i++)
        {
            scanf("%d",&key);
            s[i]=key-1;
        }
        getloop();
        while(scanf("%d",&m),m)
        {
            getchar();
            gets(z);
            for(i=0;z[i];i++);
            for(;i<n;i++)z[i]=‘ ‘;//不够位数的补空格
            for(i=0;i<n;i++)
                ans[path[i][m%cycle[i]]]=z[i];
            ans[n]=0;
            puts(ans);
        }
        printf("\n");
    }
    return 0;
}



POJ 1026 Cipher 密码问题

原文:http://blog.csdn.net/crescent__moon/article/details/19621443

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!