首页 > 编程语言 > 详细

Color the ball 树状数组的区间修改

时间:2014-10-17 21:56:55      阅读:361      评论:0      收藏:0      [点我收藏+]

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9712    Accepted Submission(s): 4998


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

Sample Output
1 1 1 3 2 1
 又涨姿势了哦!!!!!! 
要想区间修改的话,那么节点就必须往上更新,查询时往上累加。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=100000+5;
int C[maxn];
int n;
int lowbit(int x)
{
    return (-x)&x;
}
void update(int x,int y)
{
    for(int i=x; i>0;i-=lowbit(i))
        C[i]+=y;
}
int query(int x)
{
    int s=0;
    for(int k=x; k<=n; k+=lowbit(k))
        s+=C[k];
    return s;
}
int main()                                          
{

    int a,b;
    while(cin>>n)
    {
       for(int i=1; i<=n; i++)
        C[i]=0;
       for(int h=0;h<n;h++)
      {
       scanf("%d%d",&a,&b);
       update(b,1);
       update(a-1,-1);
      }
       for(int j=1;j<=n;j++)
        if(j==n)   printf("%d\n",query(j));
       else
          printf("%d ",query(j));
          //printf("%d%c",query(i),i==n?'\n':' ');  
    }
    return 0;
}

Color the ball 树状数组的区间修改

原文:http://blog.csdn.net/u013514722/article/details/40192345

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!