Girls and Boys
Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7710 Accepted Submission(s): 3535
Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find
out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.
The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:
the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)
The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
Sample Input
7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0
Sample Output
Source
题意:有n个人,一些人认识另外一些人,选取一个集合,使得集合里的每个人都互相不认识,求该集合中人的最大个数。
题解:这题就是求最大独立集,但是这并不是两个集合,而是一个集合,所以求出最大匹配后需要/2,然后代公式:最大独立集=N-最大匹配。
#include <stdio.h>
#include <string.h>
#define maxn 1010
int n, B[maxn];
bool vis[maxn];
int head[maxn], id;
struct Node {
int v, next;
} E[maxn * maxn];
void addEdge(int u, int v) {
E[id].v = v; E[id].next = head[u];
head[u] = id++;
}
void getMap() {
int i, u, k, v; id = 0;
memset(head, -1, sizeof(int) * n);
memset(B, -1, sizeof(int) * n);
for(u = 0; u < n; ++u) {
scanf("%*d: (%d)", &k);
while(k--) {
scanf("%d", &v);
addEdge(u, v);
}
}
}
int findPath(int x) {
int i, v;
for(i = head[x]; i != -1; i = E[i].next) {
if(!vis[v = E[i].v]) {
vis[v] = 1;
if(B[v] == -1 || findPath(B[v])) {
B[v] = x; return 1;
}
}
}
return 0;
}
int MaxMatch() {
int ans = 0, i;
for(i = 0; i < n; ++i) {
memset(vis, 0, sizeof(bool) * n);
ans += findPath(i);
}
return ans;
}
void solve() {
printf("%d\n", n - (MaxMatch() >> 1));
}
int main() {
//freopen("stdin.txt", "r", stdin);
while(scanf("%d", &n) == 1) {
getMap();
solve();
}
return 0;
}
HDU1068 Girls and Boys 【最大独立集】
原文:http://blog.csdn.net/chang_mu/article/details/40262109