首页 > Web开发 > 详细

POJ 2531 Network Saboteur (DFS)

时间:2014-10-23 20:43:42      阅读:696      评论:0      收藏:0      [点我收藏+]
Network Saboteur
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9385   Accepted: 4433

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

Source

Northeastern Europe 2002, Far-Eastern Subregion
 
通过将vis[i]标记为1,0来将第i个分到1,0的两类里面,C[i][cur]表示第i台电脑到第cur台电脑的权值
到n时更新最大值
 
bubuko.com,布布扣
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stdlib.h>
#include<algorithm>
using namespace std;
const int MAXN=20+5;
const int INF=0x3f3f3f3f;
int C[MAXN][MAXN],vis[MAXN],n,ans,m;
void DFS(int cur,int sum)
{
    if(cur>n)
    {
        if(sum>ans)
            ans=sum;
        return ;
    }
    m=0,vis[cur]=1;
    for(int i=1;i<=cur;i++)
        if(vis[i]==0)
          m+=C[i][cur];
    DFS(cur+1,sum+m);

    m=0,vis[cur]=0;
    for(int i=1;i<=cur;i++)
        if(vis[i]==1)
            m+=C[i][cur];
    DFS(cur+1,sum+m);
}
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            scanf("%d",&C[i][j]);
    DFS(1,0);
    printf("%d\n",ans);
    return 0;
}
View Code

 

POJ 2531 Network Saboteur (DFS)

原文:http://www.cnblogs.com/clliff/p/4046705.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!