首页 > 其他 > 详细

HDU-1236 排名

时间:2014-02-24 09:38:07      阅读:374      评论:0      收藏:0      [点我收藏+]

http://acm.hdu.edu.cn/showproblem.php?pid=1236

学会怎样按字典序排序的模板。

                                  排名

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 14043    Accepted Submission(s): 5172

Problem Description
今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的 考生,并将他们的成绩按降序打印。
 
Input
测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N < 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一
名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号 (题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理。
 
Output
对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考 号的升序输出。
 
Sample Input
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0
 
Sample Output
3
CS003 60
CS001 37
CS004 37
0
1 CS000000000000000002 20
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
#include<iostream>
#include<algorithm>
using namespace std;
struct fengshu
{
 
    char str[50];
     int  percent;
 
}xue[3001];
bool cmp(fengshu a,fengshu b)
{
 
   if(a.percent == b.percent) 
        return strcmp(a.str, b.str) < 0 ? 1 : 0; //按字典序升序 
    else 
        return a.percent > b.percent; 
}
int main()
{
    int n,m,g,i,j,t,ans;
    int ti[20],shu[20],sum;
    while(scanf("%d",&n)&&n) 
    {
        ans=0;
        cin>>m>>g;
        if(n==0)
            break;
        for(i=0;i<m;i++)
           cin>>ti[i];
         for(i=0;i<n;i++)
        {
            sum=0;
            scanf("%s",xue[i].str);
            scanf("%d",&t);
            for(j=0;j<t;j++)
            {
                scanf("%d",&shu[j]);
                 sum+=ti[shu[j]-1];
            }
            xue[i].percent=sum;
        }
       sort(xue, xue+ n, cmp);
         for(i=0;i<n;i++)
       {
           if(xue[i].percent>=g)
              ans++;
        }
        cout<<ans<<endl;
       for(i=0;i<n;i++)
       {
           if(xue[i].percent>=g)
              printf("%s %d\n",xue[i].str,xue[i].percent);
 
       }
         
    }
    return 0;
}

 

 

HDU-1236 排名

原文:http://www.cnblogs.com/cancangood/p/3562088.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!