首页 > 其他 > 详细

贪心算法之区间取点问题

时间:2014-02-24 16:16:29      阅读:312      评论:0      收藏:0      [点我收藏+]

贪心算法之区间取点问题

题目描述:
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 bubuko.com,布布扣

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1

解题思路:

此题意思给定点集S={xiyii=1.2.3...n},求用圆心在x轴上,半径为d的圆覆盖S所需的圆的最少个数。

1.先把给出的岛的坐标(xi.yi)和半径r转化为在x轴上的区间,即当d-yi>=0时,圆心位于x轴上的区间为Ii=[ xi-sqrt(d^2-yi^2) , xi + sqrt( d^2 - yi^2 )],则转化为区间选点问题。

2.S中点(xiyi),对应一个在x轴上的区间Ii=liri),按照区间右端点ri从小到大排序,在区间集合中选择一个索引最小的区间,把选择的区间和与其相交的所有区间作为一组从T中删除,直到T为空集、

3则剩下的分组的组数即为m的最小值。。。

AC代码:

#include<cstdio>
#include<cmath>
#include<algorithm>
#define MAX 1010

using namespace std;

class Range
{
	public:
		float left;
		float right;
		bool operator<(const Range &r)const
		{
			if(right<r.right||(right==r.right&&left>r.left))
				return true;
			else
				return false;
		}
};

int main(int argc,char *argv[])
{
	int n,d;
	int x,y;
	int i,j;
	int count=1,ans;
	while(scanf("%d%d",&n,&d)&&(n+d))
	{
		Range r[MAX];
		j=0;
		ans=0;
		for(i=0;i<n;i++)
		{
			Range temp;
			scanf("%d%d",&x,&y);
			if(d>=y)
			{
				temp.left=x-sqrt(d*d-y*y);
				temp.right=x+sqrt(d*d-y*y);
			    r[j++]=temp;
			}
		}
		sort(r,r+j);
		if(j<n)
			printf("Case %d: -1\n",count);
		else
		{
			float end=-0x0FFFFFFF;
			for(i=0;i<j;i++)
			{
				if(end<r[i].left)
				{
					ans++;
					end=r[i].right;
				}
			}
			printf("Case %d: %d\n",count,ans);
		}
		count++;
	}
	return 0;
}

解题方法跟求最大区间数极其相似。。。


贪心算法之区间取点问题

原文:http://blog.csdn.net/cstopcoder/article/details/19761931

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!