首页 > 其他 > 详细

Revenge of Fibonacci(杭电5018)

时间:2014-11-04 22:48:22      阅读:354      评论:0      收藏:0      [点我收藏+]

Revenge of Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 721    Accepted Submission(s): 332


Problem Description
In mathematical terms, the sequence Fn of Fibonacci numbers is defined by the recurrence relation
Fn = Fn-1 + Fn-2
with seed values F1 = 1; F2 = 1 (sequence A000045 in OEIS).
---Wikipedia

Today, Fibonacci takes revenge on you. Now the first two elements of Fibonacci sequence has been redefined as A and B. You have to check if C is in the new Fibonacci sequence.
 

Input
The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers A, B and C.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= A, B, C <= 1 000 000 000
 

Output
For each test case, output “Yes” if C is in the new Fibonacci sequence, otherwise “No”.
 

Sample Input
3 2 3 5 2 3 6 2 2 110
 

Sample Output
Yes No Yes
#include<stdio.h>
#include<string.h>
int s[10000];
int main()
{
    int n,i,a,b,c,k;
	scanf("%d",&n);
	while(n--)
	{
		memset(s,0,sizeof(s));
	    scanf("%d%d%d",&a,&b,&c);
		if(a==c||b==c)  //本题容易少考虑的情况。
		printf("Yes\n");
		else
		{
			k=0;
		    s[1]=a,s[2]=b;
			for(i=3;;)
			{
			    s[i]=s[i-1]+s[i-2];
				if(s[i]<c)
				{
				   i++;
				}
				if(s[i]==c)
				{
				   k=1;
				   break;
				}
				if(s[i]>c)
				{
				   break;
				}
			}
			if(k==1)
			printf("Yes\n");
			else
			printf("No\n");
		}
	}
	return 0;
}

Revenge of Fibonacci(杭电5018)

原文:http://blog.csdn.net/hdd871532887/article/details/40793697

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!