首页 > 其他 > 详细

POJ 2546 & ZOJ 1597 Circular Area(求两圆相交的面积 模板)

时间:2014-11-12 23:03:55      阅读:344      评论:0      收藏:0      [点我收藏+]

题目链接:

POJ:http://poj.org/problem?id=2546

ZOJ:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=597

Description

Your task is to write a program, which, given two circles, calculates the area of their intersection with the accuracy of three digits after decimal point.

Input

In the single line of input file there are space-separated real numbers x1 y1 r1 x2 y2 r2. They represent center coordinates and radii of two circles.

Output

The output file must contain single real number - the area.

Sample Input

20.0 30.0 15.0 40.0 30.0 30.0

Sample Output

608.366

Source

Northeastern Europe 2000, Far-Eastern Subregion

题意:

求两圆相交的面积!

直接上模板

代码如下:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
//#include <complex>
//#include <iomanip>
using namespace std;
const double eps = 1e-8;
const double PI = acos(-1.0);

int sgn(double x)
{
    if(fabs(x) < eps) return 0;
    if(x < 0) return - 1;
    else return 1;
}
struct Point
{
    double x, y;
    Point(){}
    Point(double _x, double _y)
    {
        x = _x; y = _y;
    }
    Point operator -( const Point &b) const
    {
        return Point(x - b. x, y - b. y);
    }
    //叉积
    double operator ^ (const Point &b) const
    {
        return x*b. y - y*b. x;
    }
    //点积
    double operator * (const Point &b) const
    {
        return x*b. x + y*b. y;
    }
    //绕原点旋转角度B(弧度值),后x,y的变化
    void transXY(double B)
    {
        double tx = x,ty = y;
        x = tx* cos(B) - ty*sin(B);
        y = tx* sin(B) + ty*cos(B);
    }
};
//*两点间距离
double dist( Point a, Point b)
{
    return sqrt((a-b)*(a- b));
}
//两个圆的公共部分面积
double Area_of_overlap(Point c1, double r1, Point c2, double r2)
{
    double d = dist(c1,c2);
    if(r1 + r2 < d + eps) return 0;
    if(d < fabs(r1 - r2) + eps)
    {
        double r = min(r1,r2);
    return PI*r*r;
    }
    double x = (d*d + r1*r1 - r2*r2)/(2*d);
    double t1 = acos(x / r1);
    double t2 = acos((d - x)/r2);
    return r1*r1*t1 + r2*r2*t2 - d*r1*sin(t1);
}

int main()
{
    double x1, y1, r1, x2, y2, r2;
    while(~scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&r1,&x2,&y2,&r2))
    {
        Point c1, c2;
        c1.x = x1;
        c1.y = y1;
        c2.x = x2;
        c2.y = y2;
        double ans = Area_of_overlap(c1,r1,c2,r2);
        printf("%.3lf\n",ans);
        //cout<<setiosflags(ios::fixed)<<setprecision(3)<<ans<<endl;
    }
    return 0;
}


POJ 2546 & ZOJ 1597 Circular Area(求两圆相交的面积 模板)

原文:http://blog.csdn.net/u012860063/article/details/41051617

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!