首页 > 其他 > 详细

Hdu 1018 Big Number

时间:2014-11-16 17:23:11      阅读:225      评论:0      收藏:0      [点我收藏+]

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26727    Accepted Submission(s): 12160


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
2 10 20
 

Sample Output
7 19
 

 
 由斯特林[striling]公式可得:lnN!=NlnN-N+0.5ln(2N*pi)

N的阶乘的位数等于log10(N!)取整后加1

log10(N!)=lnN!/ln(10) 所以len=lnN!/ln(10)+1

公式就是强大!
 
 
#include<iostream>
#include<cmath>
using namespace std;
#define pi acos(-1.0)
int main()
{
    int t,n;
    cin>>t;
    while(t--&&cin>>n)
    {
        double sum = (n*log(n)-n+0.5*log(2*n*pi))/log(10);
        cout<<(int)sum+1<<endl;
    }
    return 0;
}

Hdu 1018 Big Number

原文:http://blog.csdn.net/justesss/article/details/41173103

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!