首页 > 其他 > 详细

POJ 3077-Rounders(水题乱搞)

时间:2014-11-18 14:46:54      阅读:224      评论:0      收藏:0      [点我收藏+]
Rounders
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7697   Accepted: 4984

Description

For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and round it to the nearest thousand, and so on ...

Input

Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 <= x <= 99999999).

Output

For each integer in the input, display the rounded integer on its own line. 

Note: Round up on fives.

Sample Input

9
15
14
4
5
99
12345678
44444445
1445
446

Sample Output

20
10
4
5
100
10000000
50000000
2000
500
题意:给一个数字,然后从最后一位开始进位,满5进1,小于5变成0,比如 12345 -> 12350->12400->12000->10000;
暴力乱搞就行了。。
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <cctype>
#include <vector>
#include <cstdio>
#include <cmath>
#include <deque>
#include <stack>
#include <map>
#include <set>
#define ll long long
#define maxn 116
#define pp pair<int,int>
#define INF 0x3f3f3f3f
#define max(x,y) ( ((x) > (y)) ? (x) : (y) )
#define min(x,y) ( ((x) > (y)) ? (y) : (x) )
using namespace std;
int x;
char  s[15];
void solve()
{
	sprintf(s,"%d",x);
	for(int i=strlen(s)-1;i>0;i--)
	{
		if(s[i]>='5')
		{
			s[i]='0';
			s[i-1]++;
		}
		else
		s[i]='0';
	}
	if(s[0]>'9'){s[0]='0';printf("1");}
	puts(s);
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&x);
		if(x<=10){printf("%d\n",x);continue;}
		solve();
	}
	return 0;
}

POJ 3077-Rounders(水题乱搞)

原文:http://blog.csdn.net/qq_16255321/article/details/41245865

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!