首页 > 编程语言 > 详细

快速切题 sgu 112. a^b-b^a 大数 次方 难度:0 非java:1

时间:2014-11-19 00:15:25      阅读:289      评论:0      收藏:0      [点我收藏+]

112. a^b-b^a

time limit per test: 0.25 sec.
memory limit per test: 4096 KB

 

You are given natural numbers a and b. Find a^b-b^a.

 

Input

Input contains numbers a and b (1≤a,b≤100).

 

Output

Write answer to output.

 

Sample Input

2 3
Sample Output

-1

import java.io.*;
import java.math.BigInteger;
import java.util.Scanner;

public class Main {
	public static void main(String []args) throws IOException{
		int a,b;
		Scanner scanner=new Scanner(System.in);
		a=scanner.nextInt();b=scanner.nextInt();
		BigInteger A=BigInteger.valueOf(a);
		BigInteger B=BigInteger.valueOf(b);
		A=A.pow(b);B=B.pow(a);
		A=A.subtract(B);
		System.out.println(A);
	}
}

  

快速切题 sgu 112. a^b-b^a 大数 次方 难度:0 非java:1

原文:http://www.cnblogs.com/xuesu/p/4106946.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!