首页 > 其他 > 详细

hdoj1001--Sum Problem

时间:2014-02-26 19:04:22      阅读:398      评论:0      收藏:0      [点我收藏+]
Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 
Input
The input will consist of a series of integers n, one integer per line.
 
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 
Sample Input
1
100
 
Sample Output
1
 
5050
 
code(java):
bubuko.com,布布扣
import java.util.*;
import java.io.*;

class Main
{
    public static int sum(int n) {
        if(n % 2 == 0) return n/2*(n+1);
        else return (n+1)/2*n;
        
    }
    public static void main(String args[])
    {
        Scanner cin = new Scanner(System.in);
        int n;
        while(cin.hasNextInt()) {
            n = cin.nextInt();
            System.out.println(sum(n));
            System.out.println();
        }
    }
}
bubuko.com,布布扣

code(C):

bubuko.com,布布扣
#include <stdio.h>

int sum(int n)
{
    if(n % 2) 
        return (n + 1) / 2 * n;
    else
        return (n / 2) * (n + 1);
}

int main()
{
    int n;
    while(scanf("%d",&n) != EOF){
        printf("%d\n\n",sum(n));
    }
    return 0;
}
bubuko.com,布布扣

 

hdoj1001--Sum Problem

原文:http://www.cnblogs.com/xueda120/p/3568204.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!