首页 > 其他 > 详细

[排序]PAT1038 Recover the Smallest Number

时间:2014-02-26 23:07:47      阅读:571      评论:0      收藏:0      [点我收藏+]

1038. Recover the Smallest Number (30)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

题意:给出多个最长8位的数字,求他们组成的最小数字。

思路:这个想法比较简单了,假设两个数字字符串是str1,str2,直接排序排序规则是 str1+str2<str2+str1,可以得到最小的组合数字,注意要去掉前导0,如果全是0则只留下一个0。

#include<iostream>
#include<algorithm>
#include<string>

using namespace std;

string str[10005];

bool cmp(string str1,string str2)
{
    return str1+str2<str2+str1;
}

int main()
{
    int n,i,k;
    cin>>n;
    for(k=0;k<n;k++)
    {
        cin>>str[k];
    }
    sort(str,str+n,cmp);
    int tag=0;
    for(i=0;i<n;i++)
    {
        for(k=0;k<str[i].size();k++)
        {
            if(tag==0&&str[i][k]!=‘0‘)
            {
                cout<<str[i][k];
                tag=1;
            }
        else if(tag==1) cout<<str[i][k];
        }
        if(tag==1) break;
    }
    if(i==n&&tag==0) cout<<"0";
    i++;
    for(i;i<n;i++)
        cout<<str[i];
    cout<<endl;
    return 0;
}


[排序]PAT1038 Recover the Smallest Number,布布扣,bubuko.com

[排序]PAT1038 Recover the Smallest Number

原文:http://blog.csdn.net/zju_ziqin/article/details/19966909

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!