首页 > 其他 > 详细

2014ACM/ICPC亚洲区北京站-A Curious Matt

时间:2014-11-29 14:38:39      阅读:232      评论:0      收藏:0      [点我收藏+]
A Curious Matt
Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
   There is a curious man called Matt.   One day, Matt's best friend Ted is wandering on the non-negative half of the number line.  Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.
 

Input
   The first line contains only one integer T, which indicates the number of test cases.   For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.   Each of the following N lines contains two integers ti and xi (0 ≤ ti, xi ≤ 106), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all ti would be distinct.
 

Output
   For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.
 

Sample Input
2
3
2 2
1 1
3 4
3
0 3
1 5
2 0
 

Sample Output
Case #1: 2.00
Case #2: 5.00

HintIn the ?rst sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal.
In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.

 


Statistic | Submit | Clarifications | Back


#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
const int maxn=10010;
struct  record
{
	int l,r;
}a[maxn];
bool cmp(record c,record d)
{
	return c.l<d.l;
}

int main()
{
	int T;
	scanf("%d",&T);
	for(int k=1;k<=T;k++)
	{
		int n;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&a[i].l,&a[i].r); 
		} 
		sort(a,a+n,cmp);
		double maximal=0;
		for(int i=0;i<n-1;i++)
		{
		 	    if((double)(abs(a[i+1].r-a[i].r)/abs(a[i+1].l-a[i].l))>maximal)
		 	    {
		 	    	maximal=(double)abs(a[i+1].r-a[i].r)/abs(a[i+1].l-a[i].l);
		 	    }
		}
		printf("Case #%d: %.2lf\n",k,maximal);
	}
	return 0;
}


2014ACM/ICPC亚洲区北京站-A Curious Matt

原文:http://blog.csdn.net/holyang_1013197377/article/details/41595137

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!