首页 > 其他 > 详细

HDOJ 5112 A Curious Matt 水题

时间:2014-11-30 00:36:20      阅读:304      评论:0      收藏:0      [点我收藏+]



A Curious Matt

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 64    Accepted Submission(s): 49


Problem Description
There is a curious man called Matt.

One day, Matt‘s best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.
 

Input
The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers ti and xi (0 ≤ ti, xi ≤ 106), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all ti would be distinct.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.
 

Sample Input
2 3 2 2 1 1 3 4 3 0 3 1 5 2 0
 

Sample Output
Case #1: 2.00 Case #2: 5.00
Hint
In the ?rst sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal. In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.
 

Source
 


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

struct POINT
{
    int t,x;
}p[11000];

bool cmp(POINT A,POINT B)
{
    return A.t<B.t;
}

int n;

int main()
{
    int cas=1;
    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            p[i].t=a; p[i].x=b;
        }
        sort(p,p+n,cmp);
        double speed=0;
        for(int i=1;i<n;i++)
        {
            double X=abs(p[i].x-p[i-1].x)*1.0;
            speed=max(speed,X/(p[i].t-p[i-1].t));
        }
        printf("Case #%d: %.2lf\n",cas++,speed);
    }
    return 0;
}



HDOJ 5112 A Curious Matt 水题

原文:http://blog.csdn.net/ck_boss/article/details/41607009

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!