首页 > 其他 > 详细

hdu 1008 Elevator

时间:2014-12-02 13:33:24      阅读:243      评论:0      收藏:0      [点我收藏+]

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45946    Accepted Submission(s): 25290


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case. 
 

Sample Input
1 2 3 2 3 1 0
 

Sample Output
17 41
 

Author
ZHENG, Jianqiang
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1049 1013 1020 1170 1425 
 


CODE:
#include<stdio.h>
main()
{
    int a[100], n, i, j, sum;
    while ( scanf ( "%d", &n ) != EOF && n != 0 )
    {
        for ( i = 0; i < n; i++ )
            scanf ( "%d", &a[i] );
        sum = 6 * a[0] + 5;
        for ( i = 0; i < n - 1; i++ )
        {
            if ( a[i] > a[i + 1] )
                sum = sum + 4 * ( a[i] - a[i + 1] ) + 5;
            else
                sum = sum + 6 * ( a[i + 1] - a[i] ) + 5;
        }
        printf ( "%d\n", sum );
    }
}


hdu 1008 Elevator

原文:http://blog.csdn.net/acm_baihuzi/article/details/41677261

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!