首页 > 其他 > 详细

Problem 2147 A-B Game (数学啊)

时间:2014-12-03 19:11:36      阅读:219      评论:0      收藏:0      [点我收藏+]

题目链接:http://acm.fzu.edu.cn/problem.php?pid=2147


 Problem Description

Fat brother and Maze are playing a kind of special (hentai) game by two integers A and B. First Fat brother write an integer A on a white paper and then Maze start to change this integer. Every time Maze can select an integer x between 1 and A-1 then change A into A-(A%x). The game ends when this integer is less than or equals to B. Here is the problem, at least how many times Maze needs to perform to end this special (hentai) game.

bubuko.com,布布扣 Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers A and B described above.

1 <= T <=100, 2 <= B < A < 100861008610086

bubuko.com,布布扣 Output

For each case, output the case number first, and then output an integer describes the number of times Maze needs to perform. See the sample input and output for more details.

bubuko.com,布布扣 Sample Input

25 310086 110

bubuko.com,布布扣 Sample Output

Case 1: 1Case 2: 7


题意:

给出两个长整型的数a, b。有一种将a变化的操作为:a=a-(a%x),   其中   1<=x<=a-1;

问最少有多少次操作能使得a<=b。

代码如下:

#include <cstdio>
#define LL __int64
int main()
{
    int cas=1;
    LL t,a,b;
    scanf("%I64d",&t);
    while(t--)
    {
        scanf("%I64d%I64d",&a,&b);
        LL i=0;
        while(a>b)
        {
            a/=2;
            i++;
        }
        printf("Case %d: ",cas++);
        printf("%I64d\n",i);
    }
    return 0;
}


Problem 2147 A-B Game (数学啊)

原文:http://blog.csdn.net/u012860063/article/details/41700809

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!