首页 > 其他 > 详细

FZU Problem 2151 OOXX Game (数学啊)

时间:2014-12-03 21:29:36      阅读:245      评论:0      收藏:0      [点我收藏+]

题目链接:http://acm.fzu.edu.cn/problem.php?pid=2151


Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, there are N*M coins in this board with two symbol “O” or “X”. Then they take turns to choose a grid with symbol “O” and change it into “X”. The game ends when all the symbols in the board are “X”, and the one who cannot play in his (her) turns loses the game. Fat brother and Maze like this kind of OOXX game very much and play it day and night. They don’t even need a little rest after each game!

Here‘s the problem: Who will win the game if both use the best strategy? You can assume that Maze always goes first.

bubuko.com,布布扣 Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the state of the board.

1 <= T <=100, 1 <= n <=100, 1 <= m <=100

bubuko.com,布布扣 Output

For each case, output the case number first, and then output the winner’s name, either Fat brother or Maze. See the sample input and output for more details.

bubuko.com,布布扣 Sample Input

31 4OXXX2 4OOXXOOXX1 2XX

bubuko.com,布布扣 Sample Output

Case 1: MazeCase 2: Fat brotherCase 3: Fat brother


代码如下:

#include <cstdio>
const int maxn = 117;
char mm[maxn][maxn];
int main()
{
    int n,m;
    int t;
    int cas = 0;
    scanf("%d",&t);
    while(t--)
    {
        int k = 0;
        scanf("%d%d",&n,&m);
        for(int i = 0; i < n; i++)
            scanf("%s",mm[i]);
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                if(mm[i][j]=='O')
                    k++;
            }
        }
        printf("Case %d: ",++cas);
        if(k%2==0)
            printf("Fat brother\n");
        else
            printf("Maze\n");
    }
    return 0;
}


FZU Problem 2151 OOXX Game (数学啊)

原文:http://blog.csdn.net/u012860063/article/details/41701671

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!